WEBサービス創造記

WEBサービスを作ったり保守したりしてる人のメモブログです。

「ほかのアカウントで使用可能なアップデートがあります」と言われてXcodeのアップデートができないときの対処法

      2015/01/14

Homebrewをインストールしたところ、Xcodeのバージョンが低いという警告(Warning: Your Xcode (4.6.1) is outdated Please install Xcode 4.6.3.)が出たのでアップデートすることに。

AppStoreにアクセスして、Xcodeをアップデートしようとしたが、「ほかのアカウントで使用可能なアップデートがあります」「このアプリケーションをアップデートするには、購入時に使用したアカウントでサインインしてください」というメッセージがでてアップデートできない。

アプリケーションをFinderで開き、Xcode.appをゴミ箱に入れてから再インストールすることで解決できた。

 - Objective-C