WEBサービス創造記

WEBサービスを作ったり保守したりしてる人のメモブログです。

apt-get で指定したパッケージだけをアップデートする

   

`apt-get update`はパッケージリストのアップデートを行うコマンドです。
したがって、Apacheのアップデートを行おうとして、`apt-get update apache2`などとしても、”E: update コマンドは引数をとりません”というエラーメッセージが出るだけでアップデートはできません。

また、`apt-get upgrade`はインストール済みのパッケージを全てアップデートするコマンドなので、updateと同様に個々のパッケージをアップデートするものではありません。

では、どうやって指定したパッケージだけをアップデートすればいいかというと、`sudo apt-get install apache2`で実行すればいいようです。

$ sudo apt-get install apache2

 - Debian , ,